Ribbon Bar

The ribbon bar offers a user-friendly alternative to the traditional multiple toolbars. New users typically prefer the ribbon bar because the buttons are clearly marked. More experienced users may prefer traditional toolbars because more commands are available without switching tabs.

You can choose the ribbon bar or the traditional toolbars from the "Look" tab of the User Preferences.

The ribbon bar has different tabs organized for different modes of operation. One tab layout will not be ideal for all users. The Quick Access Toolbar can be customized to make frequently used commands available no matter which tab is displayed.

The ribbon bar has extensive tool tip capability. You can pause the mouse over any button to display its tool tip.

Ribbon Bar or Traditional Toolbars?

When the ribbon bar was introduced in Microsoft Office it was both saluted as a major step forward and criticized as a painful and unnecessary change. For new users, it was easier to use. But for users already familiar with the traditional menus and toolbars, it was a painful and unnecessary change.

We expect the reaction to the Dimension ribbon bar to be similar. Therefore we offer you a choice between the two. The "Look" tab of the User Preferences allows you to turn ribbon bar use on or off. For new users (new installs), the ribbon bar will be on by default. Existing users (upgrade installs), will retain the traditional menu and toolbars.

But before you dismiss the ribbon bar (or move away from it because you're tired of switching tabs), we would encourage you to consider the Quick Access Toolbar as a way to improve the ribbon bar's usability.

Most users will find that the "Home" tab of the ribbon bar has most of the buttons they need. But typically there are a few frequently-used commands that are missing from that tab. The Quick Access Toolbar can be configured to include the missing commands. The Quick Access Toolbar is always displayed so its commands are always available no matter which tab you're using.

Home Tab

The Home tab is intended for use when navigating through projects and drawings and doing simple measurements.

View Tab

The View tab controls the display of windows other that the main drawing window. It also has buttons to refresh the project and to copy the current view to the clipboard.

Drawing Tab

The Drawing tab allows management of the properties of the current drawing and the drawings within a project. It also has button for Pattern Searching.

Annotate Tab

The Annotate tab is used to create annotations and edit their properties.

Settings Tab

The Settings tab provides access to settings such as user preferences, measurement standards, batch import standards, etc. It also has button to export and import standards.

Planroom Tab

The Planroom tab has buttons to download multiple drawings from the planroom and to refresh the drawing list from the planroom.

Work Zones Tab

The Work Zone Tab is for the creation and editing of work zones and reviewing the Work Zone Report described in the Work Zone Overview.

Trial Tab

The Trial tab allows installation of a trial license, setting the emulation for that license and displays the trial license status.

File Menu Button

Pressing the large round button in the top left corner of the main window displays the "File Menu". This menu includes options for project backup/restore, printing and other miscellaneous functions. It also provides a list of the most recently used projects.

Quick Access Toolbar

The Quick Access Toolbar can be displayed to the right of the File Menu button or underneath the ribbon bar. This menu is highly customizable and can be used to provide access to commonly used buttons not matter which tab is displayed.

Right-hand Buttons

These buttons are displayed on the top-right edge of the ribbon bar (to the right of the tabs).

Context Help

Press this button then click on any other button or control to display the help topic for the button or control.

About the Application

Select this menu option to display information about Dimension. When you select it, the About Dimension Window will be displayed.