# eTakeoff Dimension Training Guide

This guide introduces eTakeoff Dimension. Each element is explained, followed by step-by-step activities that let you practice using the tool on a sample project. We encourage you to complete the practice steps, as they provide helpful hints, shortcuts, and suggested methods.

##Contents

**eTakeoff Dimension Training Guide** ................................................................. 1

- Using this guide ........................................................................................................ 4
- Available product editions ...................................................................................... 4
- Activating the 15-day trial ....................................................................................... 4

**About Dimension’s interface** .................................................................................. 5

- Hints, shortcuts, and tooltips ................................................................................... 5
- Context Help (F1) ..................................................................................................... 5
- User Preferences ...................................................................................................... 6
- The ribbon interface ................................................................................................ 7

**Dimension Basics** ............................................................................................... 8

- Starting a new Dimension project ......................................................................... 8
- Importing a Dimension project ................................................................................ 8
- About the Project Properties and Add Drawings windows ..................................... 8

**Navigating the Dimension window** .................................................................... 10

- Setting the scale ..................................................................................................... 11
- Favorites .................................................................................................................. 11

**Taking measurements** .......................................................................................... 14

- Using the basic Trace tools: Area, Count, Length, and Perimeter ......................... 15
- Working with Polar mode ....................................................................................... 17
- Point traces ............................................................................................................. 19
- About the Measurement List window and Measurement Summary pane ........... 21

**Modifying measurements** ..................................................................................... 24

- Editing existing measurements ............................................................................. 24

**Working with pre-defined and custom traces** ..................................................... 26

- Defining data types on traces ................................................................................. 27
- Creating custom traces .......................................................................................... 28

**Pattern Search** ....................................................................................................... 30

- Background searches ............................................................................................. 32
- User preferences related to pattern searches .......................................................... 33

**Using Extensions** .................................................................................................. 34

- Taking off traces with extensions ........................................................................... 34

**Beyond the Basics** ............................................................................................. 37

- More measuring tools ............................................................................................. 37
- Arcs and Circles ....................................................................................................... 37
Cutouts .................................................................................................................39
Synchronize measurements ...................................................................................40
Setting multiple scales on a drawing sheet .........................................................41
Calibrating scales .................................................................................................44
Selecting from overlapping measurements .........................................................46
Working with drawings .......................................................................................47
Multiple Drawing windows ................................................................................47
Drawing Comparisons and Overlays ..................................................................48
Drawing Legend .....................................................................................................52
Layers ..................................................................................................................53
Getting the most out of Dimension ..................................................................55
Configuring extensions .......................................................................................55
Work Breakdowns (WBS Codes) .........................................................................57
Working with Zones .............................................................................................58
Annotations .........................................................................................................63
Bid Codes .............................................................................................................65
Excel Integration ..................................................................................................67

System Information and Licensing.....................................................................71
System Architecture ............................................................................................71
Dimension components .......................................................................................71
Licensing ..............................................................................................................72
Stand-alone installation .......................................................................................72
Network Installation .............................................................................................73
Terminal Services (Citrix) environments ............................................................74
Back up and Restoring Dimension Data ..............................................................76
Using this guide

Throughout this guide, you’ll see the following symbols, which point to useful training topics and videos. While using the software, you can always press F1 or click the green question mark for context-sensitive Help. In this guide, the green icon represents a link to a Help topic:

😊 Link to Dimension Help topic

An extensive library of training videos is also available. You can visit the full Video Library here. In this guide, the blue icon represents a link to a training video:

👋 Link to training video.

You’ll sometimes see links to other locations in this document or on the eTakeoff website.

Practice steps

1. Instructions for completing optional training activities appear like this.

To return to this guide from the software, go to File > Help > Display Online Training Guide.

This guide shows features in the Premier edition of Dimension, with notes explaining what is included with the Advanced edition. For a comparison of the editions, see this Dimension Pricing page.

Available product editions

eTakeoff Dimension is available for purchase with an Advanced or Premier license. (The Basic edition is available at no cost or time limit.) This guide shows the features of the Premier edition, with notes on availability with an Advanced license. The differences between these editions are summarized here:

- The Basic edition includes a full-featured viewer and printer, which anyone in the organization can use to view drawings with takeoff measurements and annotations. You can complete simple takeoff with this version.

- The Advanced edition includes the full takeoff system. It does not allow you to create or edit extensions and assemblies—but you can use extensions and assemblies created by other users in your organization who have a Premier license.

- The Premier edition includes all features in the Advanced edition, plus the ability to separate drawings into zones for quantification of measurements in sections, create and edit extensions and assemblies; pattern search (autocount); an unlimited number of quantity results from each measurement; and other miscellaneous features.

Activating the 15-day trial

If you haven't yet purchased and installed a Dimension license, you will need to activate the 15 day Trial in order to complete the activities in this guide. To do this, go to the eTakeoff site and click Free Trial. Follow the instructions on that page.
About Dimension’s interface

Dimension is set up to support you in learning the product when you first get started, and to accommodate to your organization’s processes and standards.

Hints, shortcuts, and tooltips

Extensive tooltips and Hint windows assist you in completing measurements or other tasks.

- As you become more familiar with the product, you can clear the Display hints check boxes in the Hint window [A].
- When you hold your mouse over a button, the tooltip shows the available keyboard shortcuts [B].
- You can right-click any measurement to open the context menu [C]. This is an alternative way to access many of the commands shown in the list of shortcuts in the tooltip.

Context Help (F1)

As you work in Dimension, you can always press F1 to open the Help topic for the current task or window. The Help topics explain the details of all features, including some not included in this guide.
User Preferences

On the **Settings** tab, the **User Preferences** window provides numerous settings related to every aspect of Dimension. As you learn the product, explore these settings to see how you can make Dimension work for you. The examples below show a couple of these options. You’ll see more options related to respective features throughout this guide.

![User Preferences window](image)

On the **Hints** tab [A], you can set options related to the hint windows that assist you in learning the product. You might start out with all of these options selected, and gradually clear them as you improve. On the **Backup** tab [B], you can specify where automatic backups should be stored. With the **User Preferences** window open, press F1 for explanations of all options.
The ribbon interface

Videos and help topics:  
- Ribbon Bar  
- Quick Access Toolbar (Time: 2:13)

Dimension has a ribbon interface matching recent versions of Microsoft Office, Sage Estimating, and many other applications. This guide shows all screen shots in the ribbon interface.

If you see the older interface (with menus and toolbar) instead of this one, go to Admin > User Preferences. Click the Look tab and select Use ribbon bar. When you click OK, Dimension closes and restarts with the newer interface.

You may already be familiar with ribbon interfaces from working with other software products, such as Microsoft Office or Sage Estimating. If not, see the following links.
Dimension Basics

This section is an introduction to basic Dimension workflows. Once you master the basics, you can build upon your skills by working through the material in “Beyond the Basics” (starting on page 37).

Starting a new Dimension project

Video:  
- Getting Started with eTakeoff Dimension (Time: 8:30)  
- Project Properties  
- Starting a New Project (Time: 2:43)  
- Moving the Project Folder (Time: 2:02)

Dimension organizes your work into projects, or groups of drawing files, project settings, and takeoff data. Projects are associated with a single Windows folder that contains all drawings used in your project. (These files can be further organized into subfolders.) When you create a new project (Home > New), you specify the Windows folder. Dimension references the drawing files, but the drawings themselves are not modified when you perform takeoff. All measurements and annotations that you make in Dimension are stored in the project database.

During installation, a default project folder is created, which you can use to store drawings (or you can store them elsewhere if you prefer). The following file formats are supported for drawings:

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMP</td>
<td>Windows bitmap format</td>
</tr>
<tr>
<td>CAL</td>
<td>US Department of Defense</td>
</tr>
<tr>
<td>CPC</td>
<td>Cartesian Perceptual Compression</td>
</tr>
<tr>
<td>GIF</td>
<td>Graphics Interchange Format</td>
</tr>
<tr>
<td>IVS</td>
<td>IPIN Viewing System Format</td>
</tr>
<tr>
<td>JPEG</td>
<td>Joint Photographic Experts Group Interchange Format</td>
</tr>
<tr>
<td>PDF</td>
<td>Adobe Acrobat – Single and Multi-page</td>
</tr>
<tr>
<td>PLN</td>
<td>FW Dodge Planroom Graphics Format – legacy</td>
</tr>
<tr>
<td>PNG</td>
<td>Portable Network Graphics Format</td>
</tr>
<tr>
<td>TIFF</td>
<td>Tagged Image File Format – Group 3 or 4</td>
</tr>
</tbody>
</table>

Importing a Dimension project

You can create a new project by clicking Home > New. You can also import a previously saved (exported) project by double-clicking any .tpxzip file, which is the compressed file type created when you export a project. With either method, the Project Properties window opens.

About the Project Properties and Add Drawings windows

In Project Properties (Home > Edit), you enter general project information and specify the location of the project folder. This is the windows folder that contains your drawings and other files for this
This window lets you specify the Default scale, auto-backup options, and other options. When you click **OK**, the Add Drawings to Project window opens, showing a list of all drawings in the project folder and subfolders. By default, all files are selected. When you click **Add**, all selected drawings are added to the project.

To return to the Project Properties Window later, click **Home > Edit**.

**NOTE:** The project drawings and files in the Windows project folder are never modified by Dimension. All takeoff and related project data is stored in the eTakeoff database (*Dimension50ProjData.ctr*).

**IMPORTANT:** The Dimension project database stores the path to the project folder in order to display the drawings. Once you create the project, do not move the drawing files using Windows Explorer. If you need to move the drawings, click **Move** in the Project Properties window. This moves the files and updates the project folder path in the database to the new location.

### Practice steps:

1. In Windows Explorer, browse to the folder `C:\ProgramData\eTakeoffProjects\eTakeoffSamples\LaQuintaHotel`.
2. Double-click the **LA QUINTA HOTEL – Extended SampleExport.tpxzip** file. This opens Dimension and automatically starts the import process. When the import is finished, the Project Properties window opens.
3. Click **OK** to accept the default properties.
4. In the Add Drawings to Project window, verify that all files are selected, and click **Add**.
Navigating the Dimension window

Help topics and videos

- Control Panels
- Drawing Scale Edit Dialog
- Quick Access Toolbar
- Zoom in and out
- Drawing List Window
- Setting Drawing Scales (Time: 1:28)

When you first open Dimension, you see the first drawing in the project in the center panel, with control panels open on either side. You can click the down arrow in any Control Panel heading to see the list of available Controls.

Double-click an item in the Drawings List to open that drawing.

The control panels can be undocked and moved by clicking the header bar and dragging. To re-dock them, click the down arrow and select one of the Dock Control Panel options at the bottom of the list. You can also drag the cursor to one of the 4 arrows that appear when dragging to choose a location for the dock.

Use your mouse-wheel to quickly zoom in and out while viewing a drawing. To pan the view, hold down both mouse buttons and drag to the area you want to view.
Setting the scale

For each drawing, you need to set a scale. You can do this by clicking the Set Scale button on the Home tab, and then selecting a Standard Scale from the list.

Note that if you don’t set the scale before you begin measuring, you are prompted to select the scale when you begin the first measurement. Dimension lets you set multiple scales on a single drawing, such as for detail or section drawings. For more information, see “Setting multiple scales on a drawing sheet” on page 41.

Practice steps:
1. In the Drawings List (lower left pane), double-click drawing 004 A1.1 1st Floor Plan to display it.
2. In the Rotation pane, click 180 to rotate the drawing. Then click 0 to re-orient it.
3. Hold your mouse over the drawing and use the mouse scroll-wheel to zoom in and out. Also, notice that the cursor shows a blue arrow indicating that you are in “Select” mode.
4. On the Home tab, click Multi-Select and notice that your cursor changes: The cursor changes appearance based on the tools you have selected.
5. Click Select to change it back again.
6. Hold down both mouse buttons and drag the mouse over the window to pan across the drawing.
7. On the Home tab, click the Set Scale button.
8. Select 3/32 Inch = 1 Foot from the Standard Scale dropdown, and click OK.

Favorites

Help topics and videos:  Favorites
Annotation Tab
Favorites (Time: 3:32)

You can use Favorites to save commonly used measurements, annotations and detail scales as “favorites”. You can then quickly add them to other drawings and projects. Show Favorites by selecting it in the Control Panel list.
Favorites can pertain to specific projects (Project Favorites) or to all projects (Global Favorites).

Using Project Favorites to copy multiple traces to other drawings

On the Home tab, click Multi-Select and select multiple takeoff items. Zoom out. Choose the cursor position deliberately (for example, at point [A]), as this determines the position of your cursor when you drag the favorite back to a drawing [B]. Then, click and drag the items into the appropriate Favorites folder [C].

Once measurements are added to Favorites, you can drag the items—or the entire folder—onto other drawings as needed. The position of your cursor when you drop the items is the same relative to the starting point when you dropped them into Favorites. Note that you can right-click and rename the Favorites item for future reference. If you drag the favorite measurement onto the drawing it will be replicated exactly as it was saved. If you double-click on the favorite, you can then perform a new takeoff in any format, but all the variable information will be replicated in the new takeoff measurement.

Using Global Favorites to create a library of annotations

On the Annotate tab, click Text. Click once in the drawing and begin typing a word, such as “Reviewed.” Press Enter, and then click and drag the annotation to Global Favorites. Adding it to Global Favorites makes it available to you from any project. If you put it in Project*Favorites, it is available for any drawing in this project, but not other projects.
To re-use this annotation, drag it to subsequent drawings in any project.

See Error! Reference source not found. on page Error! Bookmark not defined. for more information about annotations.

**Practice steps:**

1. In **Control Panel 2**, click the down arrow and select **Favorites**.
2. Double-click drawing **005 A1.1 1st Floor Plan** to open it. Use the mouse wheel to zoom out so you can see the entire floor plan.
3. Click **Multi-Select**, and then click and drag to select all measurements on the drawing.
4. Choose a deliberate cursor location in the selection. Click and drag that point to **Favorites > Project Favorites**.
5. Now double-click drawing **005 A1.2 2nd Floor Plan** to open it.
6. Click the folder containing the measurements in **Project Favorites** and drag it to the drawing, dropping your mouse at exactly the same location that you used in step 4.
7. On the **Annotate** tab, click **Text** and create a text annotation. Drag it to **Global Favorites** to store it for re-use.
Taking measurements

Dimension provides a variety of measuring tools, called Traces, which you see in Control Panel 1 [A]. When you first begin using Dimension, the takeoff buttons on the Home tab [B] are set up to automatically help you create custom traces as you work. This lets you build a library of traces for use with all projects. For example, clicking Home > Area opens the Easy Trace Creation/Edit window, where you can create a new trace, name it, and select its display characteristics.

The new trace is then added to the Traces list [A] for use at any future point. Use the four standard ribbon bar measurement buttons [B] (Area, Count, Length, or Perimeter) when you want to start a new measurement not in your trace library. Otherwise, use the Traces list in the Control Panel. Simply double-click a trace to begin a new measurement.

**NOTE:** In addition to traces, Dimension’s extension feature lets you add additional variables to a trace to use with estimating assemblies. Dimension comes with several pre-defined extensions that you can use for takeoff with an Advanced license. With a Premier license, you can create and modify additional extensions and provide them to any users with an Advanced license. Extensions are explained in the Beyond the Basics section, under “Configuring extensions” on page 55.

When you hover over one of the measurement types, notice the extensive tooltip to help you remember shortcuts and steps to complete the measurement [C].

- While using any trace, press Z to open the Easy Trace Creation/Edit window.
- When you finish a measurement, press D to enter a description for the measurement (as indicated in the tooltip [D]). This helps you differentiate measurements of the same type on a drawing. If you don’t assign a description, the name of the trace is used by default.
Using the basic Trace tools: Area, Count, Length, and Perimeter

Clicking any of the tools, such as Area, changes the cursor to an arrow with a ruler, indicating you are in Trace mode.

For an Area trace, click multiple times in a clockwise direction to define the shape of the area you want to measure. (If you click in counter-clockwise direction, the area is treated as a negative value or cutout.) As you click, the area of the shape is shaded green and each point registers as a yellow circle.

To finish any trace, press Enter or S to return to select mode. While creating a trace, press the H key to toggle the display of cross-hairs.

Notice that the Quantity List pane shows both the Perimeter and the Area of the shape you defined. When multiple measurement types are included with a trace, the primary measurement is shaded blue (Area in this example [A]).

A Length trace lets you click multiple times to measure the length (total distance between points).

For a Count trace, click each object you want to count. As you click, each item registers as a red circle with a green outline.
When you finish (by pressing Enter or S), the **Measurement Summary** pane shows the quantities you have accumulated so far *for this drawing* (not for the entire project).

A **Perimeter** trace calculates the perimeter of points defined. **Length** and **Perimeter** traces are distinguished by the results when you complete the measurement.

**Length** traces measure the distance between clicks, stopping at the final click. In this example, clicking points [A], [B], [C], and [D] gives you the lengths of walls [AB], [BC], and [CD], but not wall [AD].

A **Perimeter** trace completes the measurement by closing the shape. The same four points in this example give you the perimeter of all four walls.

Once you add measurements to a drawing, notice that the **Drawing List** shows the drawing in bold text with a special icon.
## Working with Polar mode

### Help topic: Polar mode

While completing a trace, the cursor can be in **Freehand mode** (default) or **Polar mode**. In **Freehand mode**, the cursor allows unrestricted positioning to find the next measurement point on the drawing. In **Polar mode**, the measurement line is forced into a vertical or horizontal line.

To force a measurement into a vertical or horizontal line, press the Ctrl key while moving the mouse. This temporarily engages **Polar mode** for as long as the Ctrl key is held. If you wish to stay in polar mode during measurements, click **Polar mode**. In this mode, pressing the Ctrl key while moving the mouse will temporarily engage Freehand mode.

### User Preferences related to Polar Mode

Notice that additional angle options are available in the **User Settings** window.

- On the **Drawing** tab, select **Disable polar mode when counting** to allow free movement of the cursor when using the Count trace. Select or clear the **Polar mode snap angles** according to the angles you are likely to need. (Ninety-degree snap is always available.)

- On the **Look** tab, **Show rubber banding before mouse is pressed** lets you use rubber banding.

© Copyright 2004-2018 eTakeoff, LLC
Practice steps:

1. In drawing 004 A1.1 1st Floor Plan, zoom in to grid B5, where you see the Laundry room.
2. In the Traces control panel, click Area.
3. Starting at the top left of the Laundry room, hold down the Ctrl key and click each corner in clockwise sequence to define its area excluding the bathroom and elevator. (There are 8 points total.)
4. Press S when you are finished.
5. Next, click Perimeter.
6. Directly to the left of the Laundry room, click to measure the perimeter of the Electrical room (4 points total).
7. Press S when you are finished.
8. Return to the area trace over the Laundry room. Click to select it, and then press D.
9. Enter “Laundry Room Area,” and press Enter. This names the trace so you can easily associate it with its location on the drawing. Notice that this description now appears in the Quantity List and Measurement Summary panes.
10. Assign the description “Electrical Room” to the perimeter trace you completed.
Point traces

Videos and help topics:  
- **2 Point Lines and 2 Point Rectangles**
- **Disconnected Points**
- **2 Point Lines and 2 Point Rectangles** (Time: 2:46)

The remaining traces—including **2 Point Line**, **2 Point Rectangle**, **1 Point line**, and **Disconnected Point**—let you complete and refine length and area measurements. You first select one of the basic measurement types (such as area or length) and then click the point trace you want to use.

A **2 Point Line** trace creates disconnected lines. To complete a **2 Point Line** trace, first click **Length**, and then click **2 Point Line**.

In this example, clicking [A], [B], [C], and [D] gives you the length of walls [AB] and [CD], excluding walls [BC] and [DA]. In the **Quantity List**, the **Length** is the total of all lengths. The **Group Length** is the horizontal length from point [A] to point [C].

A **2 Point Rectangle** trace creates multiple disconnected rectangles. To complete a **2 Point Rectangle** trace, first click **Area**, and then click **2 Point Rect**.

In this example, clicking points [A], [B], [C], and [D] gives you rectangle [AB] and rectangle [CD].
A 1 Point Line trace creates a series of lines originating from a single point, like spokes on a wheel. To complete a 1 Point Line measurement, click **Length**, click the starting point of the lines, and then click **1 Point Line**.

In this example, clicking points [A], [B], [C], and [D] gives you the lengths of lines [AB], [AC], and [AD].

A **Disconnected Point** trace lets you make multiple area measurements of the same type in a series. To complete this type of trace, click **Area**, click the points for the first area, then click **Disconnected Point**, and continue with the next area.

In this example, clicking the points for rectangle [A], then clicking **Disconnected Points** followed by the points for rectangle [B], gives you the area of the two disconnected rectangles [A] and [B].

Alternately you could click the points for rectangle A and then press G (the keyboard shortcut for **Group**) to start the next group of points.

---

**Practice steps:**

1. On sheet **017 A2.1 Exterior Elevations**, drawing **2 East Elevation**, use the **Disconnected Point** tool to measure the total area covered by the windows.

2. On the same sheet, drawing **1 South Elevation**, use the **2 Point Line** tool to measure the lengths of each of the tan accent areas.
About the Measurement List window and Measurement Summary pane

Videos and help topics:  
- **Measurement List**
- **Trace Properties Window**
- **Measurement List** (Time: 4:50)

The **Measurement Summary** pane in the **Control Panel** shows all measurements in the current drawing. It is used frequently for exporting takeoff data to Microsoft Excel or other applications.

With the **Measurement Summary** pane open, click the **Measurement List** button. This shows the **Measurement List**, which displays all measurements for the **project**.

An arrow to the right of a column heading indicates that the list is sorted by that column. Numbers in the row header, such as these **Description** and **Trace**, indicate that the list is sorted first by **Trace** and then by **Description**. This is the default sort order.

The **Drawing** column indicates the drawing to which the measurement applies. Notice that the sample project already contains takeoff measurements for drawings **005 A1.2 2nd Floor Plan** and **007 A1.4 Roof Plan**.

To sort the list by a column, right-click the column and select **Sort by**. By default, this list is sorted by trace and then by description.

You can click the **Summarize** button to show totals and subtotals.
Notice that you can also delete or insert columns based on the information you need to see. For each measurement, the four data types assigned when creating the trace (such as area, length, or a variable) can be displayed. These four types are available as output types for each measurement.

To see the quantity types used for each measurement, click a cell and then click **Edit Trace**. The data types listed correspond with the quantities in the **Measurement List**.

**NOTE:** The measurement selected for **Data Type 1** in the **Trace Properties** window determines the primary measurement type, which is the blue shaded measurement in the **Quantity List**.
Once you arrange the columns as needed, you can right-click a column heading and select **Save Column Configuration**. The configuration is then saved and is available for future access.

### Practice steps:

1. In drawing A1.1, First Floor Plan, zoom in to location B5, the Laundry room.
2. With the **Measurement Summary** pane open, click the **Measurement List** button.
3. Arrange the columns so that the **Drawing** column is first, followed by **Description**, **Trace**, and all columns for quantity types 1 and 2.
4. Right-click a column header and select **Save Column Configuration**.
5. Assign a name to the configuration and click **Save**.
6. Double-click any measurement in the list to go to that measurement in the drawing.
Modifying measurements

Videos and help topics:
- Measurement Summary
- User Preferences
- Settings tab
- Edit Measurements (Time: 2:16)

You have several options for refining and correcting your traces as you complete your measurements. Keep these tips and shortcuts in mind.

Editing existing measurements

If you wish to edit an existing measurement, use the Add Points, Edit Points or Move/Copy buttons in the Measurement Edit section of the Home tab.

- To correct only the last segment (click), click Undo, or press Ctrl + Z or Backspace.
- If you make a mistake while measuring, you can cancel the entire measurement by clicking Cancel or pressing Esc.
- While clicking the corners of an area trace, you can hold down the left mouse button and pause to auto-zoom for more accurate placement.
- To delete a measurement, click to select it and press Delete.
- To delete several measurements at once, click Multi-Select, and then either select each measurement, or click and drag to form a rectangle around all measurements to select them simultaneously Press Delete.
Moving or copying measurements

To move a measurement, click the measurement to select it, click **Move/Copy**, and then click and drag the measurement to the new location. (Notice the extensive help information when you hover over the **Move/Copy** button.

To copy a measurement, click the measurement to select it, click **Move/Copy**, and then hold down the Ctrl key as you click and drag the measurement. This creates a copy, which you can then move as needed. This option is particularly useful if you are estimating alternate options for a client. Use a work breakdown category to define the alternates. (See “Work Breakdowns (WBS Codes)” on page 57.) Create the measurements and assign the alternate—then copy the measurements and simply assign new alternates.
Working with pre-defined and custom traces

Videos and help topics:
- Trace List/Tree Control
- Easy Trace Creation/Edit Window
- Trace Properties Window
- Trace Grid Window
- Edit Measurements (Time: 2:16)

The standard takeoff traces are area, length, perimeter, and count. You can take advantage of numerous other pre-defined traces by expanding the Templates folder in the Traces list. For example, in the Templates > Flooring folder, the Carpet & Base – Area, Perimeter trace lets you delimit an area, such as a room, and calculate the square footage of carpet needed plus the linear feet of baseboard needed.

Double-click a trace in the Templates list to begin the measurement. This example shows a Carpet & Base measurement of the Office. The Measurement Summary list shows the perimeter as well as the carpet area.
Defining data types on traces

For every trace, you can define additional data types, with one measurement quantity assigned to each (such as area, length, perimeter, and count). The measurements are then displayed in the appropriate data type column in the Measurement List.

To assign data types to a trace, right-click the trace in the drawing area and select Edit Trace. The Edit Takeoff Trace window lets you specify the values to store for each data type. Remember that the Data Type 1 assignment [A] is treated as the primary measurement type and is shaded blue in the Quantity List [B].

With the Premier edition: You can designate variables created in an extension as additional output in the Measurement Summary. For example, you might record part numbers or other spec information during takeoff. There is no limit to the number of columns you can generate in this manner. See “Configuring extensions” on page 55.

Notice the Show Quantities check boxes [C], which you can use to show or hide the four quantity types.

With the Advanced edition: You can assign up to four data types.
Creating custom traces

You can create your own library of traces and use them in any project. To do this, click one of the four basic measurement types on the Home tab, set the properties for the trace, and click OK. The new trace is added to your Traces list.

To organize your Traces list, on the Settings tab, click Edit Traces. Click and drag a trace on the right to a folder on the left to move it. Notice that you can right-click a folder and select Add New Folder to further organize your traces.

Once you create a new folder, create a new trace or move an existing trace to the folder to prevent the folder from being removed when you close the window. To create a new trace, right-click in the right-hand pane and select Add New Trace.
Practice steps:

1. Click Area, and then press Z.
2. In the Easy Trace Creation/Edit window, enter “Slab with Finish” as the Description.
3. For Points, select Square – Filled and assign the color orange. Don’t change the Transparency setting.
4. For Lines, select Solid line and assign the color orange. Don’t change the Transparency setting.
5. For Fill, select No fill.
6. Make sure the Save as Standard Trace check box is selected and click OK.
7. Click Settings > Edit Traces and move your trace to the Templates > Concrete folder.
9. Create a new measurement using the trace you just created. Remember to press S to finish.
10. Press D, and enter the name “New Slab with Finish.”
11. Verify that your new measurement appears in the Measurement Summary list.
Pattern Search

Videos and help topics:  
- **Pattern Search Overview**
- **Pattern Search Part 1** (Time: 6:13)
- **Pattern Search Video 2 Multiple Patterns and Drawings**  
  (covers background search) (Time: 2:46)

**With the Premier version:** Pattern search, also known as Autocount, lets you search for multiple symbols across a drawing. To do this, you first designate the area to be searched (using a rectangle or polygon) and then designate the pattern for which to search.

If you click a trace in the Templates list before starting pattern search, the search results are automatically assigned to that trace.

In this example, the pattern search results will be assigned to the **Fire and Security > Smoke Detector** trace.

To specify the area to be searched, click **Add Search Rectangle** or **Add Search Polygon**. To create a rectangle, click in the top left corner of the area you want to search, and then click the bottom right corner. To create a polygon, click the points of the polygon and then press S. The selection is shaded yellow. (Press Delete to remove this search area.

You can show or hide the search area by clicking **Show Search Areas**. Click **Start/Resume** to begin.

Click and drag to select the pattern to search for. In this example, the search is for fire detectors.
Once you release the mouse, the **Edit Pattern for Search** window opens. You can zoom in and use the editing tools [A below] to minimize white space and eliminate artifacts of other drawing elements.

Notice that **Smoke Detector – Count** is selected as the trace [B], because it was selected when the pattern search was initiated. If no trace is selected or you want to change it, you can click **Select**.

You can search for the pattern in any rotation [C] and select **Search immediately** to show the results immediately when you click **Search**. In the list of search areas [D], select the areas to search.

In the **Pattern Search Review** window, the title bar indicates the number of matches found and the number unselected [A below]. All matches are shaded green, which means they are selected as matches. (Results not selected are shaded white.) You can zoom in [B] to view the search results more closely.

Notice the double-arrow symbol in the lower-right corner of the first match [C]. Use this to expand the area shown in the results. When you do this, the search results are not changed, but you can see each result with more context to help you decide whether to include it in the trace.
You can also change the minimum percentage of pixels to match [A below] (in this case, 80% is selected). If you think too few or too many matches were found, you can change this value.

Expanding the area using the double-arrows reveals that a Smoke Detector with Auxiliary symbol [A] was returned as a match. Clicking a match toggles its selection (green is selected, white is not selected). When you click Save, the Smoke Detector trace resulting from the pattern search appears in the Measurement Summary [D].

Pattern search also lets you search across multiple drawings, and you can search for multiple symbols simultaneously. Searches can run in the background while you continue to do takeoff.

**Background searches**

If you leave the Search immediately check box cleared [A], the Pattern Search list in Control Panel 2 lets you see the progress of multiple searches while you continue to work in the drawing. Hold your mouse over a search to see the image for which it is searching [B].
User preferences related to pattern searches

In Settings > User Preferences > Pattern Search tab, you can configure colors, cached drawings, and maximum number of background searches if you find that multiple searches slow the application.

Practice steps:

1. Open drawing 090 E2.0 Electrical Lighting, Power Site Plan First Floor.
2. On the Drawing tab, click Add Search Rectangle, and designate the building area as the search area (excluding surrounding site elements, text, and other areas of the drawing).
3. Click Show Search Areas to hide the yellow shading.
4. Click Start/Resume.
5. Zoom in to smoke detector, such as the one in the Video Server room (grid line B between lines 3 and 4) and select a tight rectangle around it.
6. Select Search immediately, and then click Search.
7. When the search is complete, review the results and clear any false matches. (Click Review on Drawing to see the matches in context.)
8. Click Save to add the Smoke Detector trace to your measurements. Review the Measurement Summary to make sure the correct number was returned.
Using Extensions

Videos and help topics:

- Extensions Overview
- Standard Extension Maintenance
- Grid
- Riser
- Joist
- Roll
- Extensions Part 1 (Time: 3:14)
- Extensions Part 2 (Time: 8:32)

Extensions let you add variables for additional input and output parameters to any trace. In addition to the four standard quantity types shared by all traces—Length, Area, Perimeter, and Count—extensions can collect additional input and calculate new quantities based on the additional information.

With an Advanced license, you cannot create or modify extensions; however, a variety of pre-built extensions are included with the Advanced version. You can also use extensions created by the Premier edition.

With the Premier edition: You can create and modify extensions, and export them for use by colleagues using the Advanced edition. See “Error! Reference source not found.” on page Error! Bookmark not defined.

Taking off traces with extensions

In this example, the Wood Wall – Length, Studs, & Drywall trace has been used to measure interior walls. This trace is under Templates > Frame & Drywall > Wood. Notice the special icon indicating the trace has an extension: . The e in the icon is red because the extension is incomplete.

In the Measurement Summary, double-click the trace to see its details.
In addition to the length of the walls, the `WallHeight`, `StudSpacing`, `Sides` of sheetrock, and `Sheetsize` variables [A] are associated with the trace because of its extension.

From these additional values, the extension calculates quantities for `TotalPlate`, `Studs`, number of drywall sheets, and so on [B].

Red shaded areas indicate values that still need to be entered, or that will be calculated when the remaining variables are entered.

Once all variable values are entered [C], the extension icon changes to blue.

**TIP:** During project takeoff, you’ll find that you use certain trace-extension combinations quite often. If you start your trace by clicking it in the `Traces` list, you’ll need to fill in the variables each time. However, once you enter variables the first time, you can save the trace as a `Project Favorite` to preserve any variable values. Later, double-click the extension in `Project Favorites` to use it on other drawings. Variable values are preserved in the new location.

To create or modify extensions using the Premier edition, on the `Settings` tab, click `Edit Extensions`. Find the extension you want to inspect and click `Edit`. This example shows the `Frame & Drywall – Wood` extension used with the `Wood Wall` trace.

With the **Advanced edition:** To import extensions created in the Premier edition, go to `Settings > Import Standards`. 

---

<table>
<thead>
<tr>
<th>Wood Wall - Length, Stud &amp; Drywall</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ProjectWallType</strong></td>
</tr>
<tr>
<td><strong>WallSize</strong></td>
</tr>
<tr>
<td><strong>WallHeight</strong> (ft)</td>
</tr>
<tr>
<td><strong>StudSpacing (in)</strong></td>
</tr>
<tr>
<td><strong>Sides (ea)</strong></td>
</tr>
<tr>
<td><strong>Sheetsize (in)</strong></td>
</tr>
<tr>
<td><strong>TopPlate</strong></td>
</tr>
<tr>
<td><strong>BottomPlate</strong></td>
</tr>
<tr>
<td><strong>TopPlateLength</strong></td>
</tr>
<tr>
<td><strong>BottomPlateLength</strong></td>
</tr>
<tr>
<td><strong>TotalPlate</strong></td>
</tr>
<tr>
<td><strong>Sheets</strong></td>
</tr>
<tr>
<td><strong>SheetsBasedOnSf</strong></td>
</tr>
<tr>
<td><strong>JointCompound</strong></td>
</tr>
<tr>
<td><strong>JointCompound in</strong></td>
</tr>
<tr>
<td><strong>Screws</strong></td>
</tr>
<tr>
<td><strong>RedBelt</strong></td>
</tr>
</tbody>
</table>

**Measurement Summary**

- **Description**
  - Area
  - Carpet & Base - Area, Per
  - Perimeter
  - Wood Wall - Length, Stud & Drywall

- **Unit**
  - ft²
  - ft
  - in

- **Spec**
  - Custom
  - Default

- **Quantity**
  - Unit
  - Custom
  - Default

- **Calculation**
  - Manual
  - Default

- **Help Attachment Link**
  - Open statement outside Dimension not in embedded browser window

---
Practice steps:

1. Double-click drawing 004 A1.1 First Floor Plan to open it.
2. In the Traces list, go to Templates > Flooring and click Carpet & Base – Area, Perimeter.
3. You need to measure for carpet and baseboards to be installed in the General Manager’s office, Gift Shop, and Board Room. Trace these three locations using any of the takeoff tools.
4. Press S when you are finished.
5. In the Quantity List, for NumberOfDoors, enter 4. Notice that the BaseLengthTotal is calculated to reflect the change.
6. Press D, and enter “Carpet & Base, GM, Gift Shop, Board Room.”
Beyond the Basics

Now that you’ve been introduced to Dimension’s basic workflow, you can refine your skills using the information in this section. You can approach these topics in any sequence. Each topic references the skills you’ve already learned, so if you need to brush up on something, just go to that topic in the “Dimension Basics” section, and then return here when you’re finished.

More measuring tools

Arcs and Circles

You can measure an arc by indicating its starting and ending points.

Start an Area measurement such as the one shown here. When you get to the arc, click the beginning [A], middle [B], and end [C] of the arc. Press C on the keyboard, and notice that Dimension fills in the points needed to make the arc [D].

In Settings > User Preferences, on the Drawing tab, you can set the number of degrees between arc points to control the number of points filled in by Dimension [D]. The default setting is 12 degrees, which resulted in ten points for the arc in the example above.
The last point you clicked before pressing C can be the starting point of the next arc. Click twice more to mark the middle and end, and press C again. Continue in this manner and press S to end the trace.

To create a circle, you simply create two semi-circles. Click Area, and then click on points at 0°, 90°, and 180° to mark the first half of the circle [A]. Press C to generate the first arc. Then click at 270° and back at 0° [B]. Press C again to finish the circle [C].

About Arcs and Polar Mode

Clicking Polar Mode while measuring forces your clicks to conform to vertical or horizontal lines (or other snap angles if you configure them in Settings > User Preferences > Drawing tab). However, for arcs and circles or other non-perpendicular points, this isn’t helpful. You can press the Ctrl key while measuring to temporarily disable Polar Mode.

▶ Practice steps:

1. Double-click drawing 002 ST1.1 Site Plan to open it.
2. Zoom in to one of the curved, landscaping areas in the parking lot and use arcs to measure its area.
3. Next, open drawing 047 ST3 Underground Detention Details and zoom in to the Inspection Manhole on the 24” HDPE Manifold Detail section.
4. Measure the area of the manhole using a circle.
Cutouts

Video:  🎥 Measurement Cut Outs (Time 1:36)

Cutouts let you subtract one area from another, such as when you need to deduct the size of openings from exterior finish area measurements.

Normally areas are measured clockwise. To create a cutout, start by measuring the area in a clockwise direction [A]. Then, press G (or click Disconnected Point) to start the cutout, moving in a counter-clockwise direction [B].

If the area has multiple cutouts, you can continue adding them using disconnected points until you are finished. Press S to stop the measurement.

▷ Practice steps:

1. Double-click drawing 017 A2.1 Exterior Elevations to open it.
2. Zoom in to the small storage structure to the left of the hotel in the East Elevation.
3. Measure the area to be finished with reddish brown clay brick by first measuring the total area and then using a cutout to remove the opening.

   **TIP:** The top of the opening is curved. Use an Arc to measure this portion of the opening. (See Arcs and Circles starting on page 37.)
Synchronize measurements

In the **Measurement Summary** list (in **Control Panel 2**), you can double-click a measurement to make the drawing view jump to that measurement. This works as long as the **Sync** check box [A] is selected in the **Measurement Summary** list.
Setting multiple scales on a drawing sheet

When a drawing sheet contains multiple section or detail drawings, they might not all use the same scale. Dimension lets you set multiple scales per drawing sheet so your measurements on each drawing are accurate.

Each drawing sheet has a scale. In this example, the scale is \( \frac{1}{2} \text{ Inch} = 1 \text{ Foot} \), which matches the Elevation drawing on the right. However, notice that the Typical Room Module section uses the scale \( \frac{1}{4} \text{ Inch} = 1 \text{ Foot} \).

To add scales, you denote the area of the drawing that uses a different scale.

On the Drawing tab, click Detail Scales. In this window, you add a description and select a Standard Scale—or, you can enter the Drawing Distance and Actual Distance if a standard option does not apply.
Click **Set Border**, and indicate the area by clicking in the top left and lower right corners of the area covered by the detail scale. (Notice the **Hint** window, which tells you exactly how to specify the border.) When you finish, click **OK** to close the window.

The **Detail Scale List** window lets you add or modify the scales that apply to the active drawing. Once you have added a scale, this is the window that opens when you click **Detail Scales** from the **Settings** tab. You can have as many scales on a drawing as needed.
When you complete measurements inside the area denoted for the detail scale (or click an existing measurement), the **Scale** setting on the **Home** tab shows you the scale that applies to the section—not the scale that applies to the entire drawing.

Add detail scales to Favorites

From the **Detail Scale List** (Drawing > Detail Scales), you can drag a detail scale to **Project Favorites** or **Global Favorites** if it is one you use often.

### Practice steps:

1. Double-click drawing **034 A10.1 Front Desk Details** to open it. No scale has been set yet. Notice that details 8, 8A, 9, 10, and 11 use a different scale than the other drawings.
2. Set the **Drawing Scale** to **1-1/2 Inches = 1 Foot**, since most of the details use that scale. (See *Setting the scale* on page 11.)
3. On the **Drawing** tab, click **Detail Scales** and set the scale for the detail drawings in the upper left area to **3 Inches = 1 Foot**.
4. Zoom in to the **9 Edge Detail** drawing and do an area measurement of the **CT6** tiles to make sure the correct scale is applied to it.
5. On the **Drawing** tab, click **Detail Scales** and drag the new scale to **Project Favorites**.
Calibrating scales

If you want to check the accuracy of the scale indicated in a drawing, you can calibrate the scale. You do this by opening the scale setup window and clicking Calibrate.

In this example, let’s imagine that we know the width of a specific doorway to be precisely 3 feet. To calibrate the drawing, click points [A] and [B].

This returns you to the settings window, where you can enter the Actual Distance, 30 Inches. Clicking Normalize lets you convert the drawing and actual distances to an option in which one of the values is 1. In some cases, you can choose between a decimal or fractional representation of the other.
number. If the measured distance does not correspond to a perfect fraction, the percentage shows the degree to which a fractional equivalent is off.

Practice steps:
1. Double-click drawing 034 A10.1 Front Desk Details to open it.
2. Set the Drawing Scale for the E Elevation detail by using Calibrate. (See Setting multiple scales on a drawing sheet starting on page 41.)
3. Click Normalize to convert the scale to a 1-based value.
4. Click Set Border to indicate the location of the scale.
Selecting from overlapping measurements

Once you’ve completed extensive takeoff measurements on a drawing, you’ll find that the drawing can become quite busy! Some of your measurements might overlap, which can make it difficult to select specific items.

To select precisely the measurement you need, verify that you’re `Select` mode. Then right-click near the overlapping items and select `Select From List`. In the window that opens, double-click the measurement to select it.

Practice steps:

1. Double-click drawing 005 A1.2 Second Floor Plan to open it.
2. Zoom out so you can see the entire drawing in the window.
3. Right-click an area measurement in one of the bathrooms, and select `Select From List`.
4. Double-click a measurement in the list to select it.
Working with drawings

Multiple Drawing windows

You can open an unlimited number of additional drawing windows (View > Extra Drawing Window) if you need to reference other project documents while you work. Click the drawings list dropdown to select the drawing to open.

Notice that you have access to all of the annotation tools here, but no takeoff tools. Use the Swap Drawing button to switch the drawing in this window with the one in the main window if you need to take or modify measurements. When you finish with those changes, return to the extra drawing window and click Swap Drawing again.

When you close Dimension, all extra drawing windows and their locations are preserved and will open automatically next time you open the application.
Drawing Comparisons and Overlays

Help topics:

- Drawing Comparison
- Copying Measurements and Annotations

Dimension lets you overlay two different drawings to see the differences between them. This involves three basic steps:

1. Align the drawings and view the overlay.
2. Revise takeoff measurements with the overlay active. (Measurements remain on the original drawing.)
3. Move all measurements from the original drawing to the revised drawing.

On the Drawing tab, click Compare to New Drawing. If you have not yet selected drawings to compare this one to, the Drawing Comparison Properties window opens. You can select drawings in this project or in a different one. Alternately, you can browse to a drawing if it is not already included in a Dimension project.

Aligning the drawings

Once you click Align, the Drawing Comparison Alignment window opens. Often drawings that are generated using software do not need to be aligned. With both drawings open, elements that are exactly the same are shown in black. Where differences are found, the old drawing is shown with red text and lines, and the new one is shown in blue.

In this example, the fire lane of the parking lot has been expanded. All other elements of the two drawings are aligned (shown in black) and you can easily see areas of difference.

The Drawing Comparison Alignment window lets you adjust the alignment using several different methods.

- You can rotate the drawing by selecting an option for New Drawing Rotation.
• **Use 2 Point Align** to associate two points in the old drawing with two points in the new drawing. The Help window guides you through the process. Click on a point in the first drawing, and then click on the corresponding point in the second drawing. Green lines [A] indicate the matching points.

When you set the fourth point, messages ask you to verify the distance between the points in the first and second drawings. The two drawings are aligned and re-scaled based on the matching points. Black lines show elements that match exactly.

• Move or rotate the new drawing using the arrow buttons. (If the drawings need to be rotated, do this first, and then use the arrows to align them.) The Ctrl, Shift, and Alt keys work together to speed up or slow down the effect of clicking the arrows. Holding one of these three keys down while clicking the arrows makes the movements four times larger. Holding two of the keys down makes them sixteen times larger, and holding all three down makes them 64 times larger. You can also left-click and drag to move the new (blue) drawing into alignment line with the old (red) one.

• The **Auto-Scale** button is available if the scales of the two drawings have been set differently. Clicking this button automatically resizes the new drawing to the old drawing. You might still need to use the arrows to align the drawings.
Adjusting measurements to reflect revisions

To modify a measurement, click to select it [A], and then click **Edit Points**. Drag the first point to the new border [B], and then drag the second point [C]. Press S when you are finished.

Moving measurements between drawings

When you modify your takeoff to reflect the drawing revisions, the measurements remain on the original drawing. Next you’ll move them to the revised drawing.

With a drawing comparison active, on the Home tab click **Multi-Select**. Click and drag to select all takeoff in the first drawing, and then right-click on a measurement. Select **Drawing Comparison > Move/Copy Measurements and Annotations**.

In the **Copy Measurements and Annotations** window, select **MOVE** to move the measurements to the new drawing. This deletes the measurements from the first drawing, so you can continue with
takeoff in the new drawing. (Selecting **COPY** preserves the measurements in the original drawing, which means the takeoff quantities will be duplicated.)

In the **Drawing List**, the bold text and icon indicating which drawings have associated measurements are adjusted when you move measurements. If you move all measurements, the new drawing has the icon ![icon] while the old one does not.

### Comparing the drawings

To un-clutter the drawing while you work with the overlay, you can right-click in a clear area of the overlaid drawings and select one of the **Show** options. In this example, the new (blue) drawing is emphasized.

![Comparison Options]

### Practice steps:

1. Double-click drawing **200 A4-03 Interior Elevations** to open it.
2. On the **Drawing** tab, click **Compare to New Drawing**.
3. Select the drawing **201 A403 Interior Elev – Addenda 1**, and click **Align**.
4. Verify that the drawings are aligned, and click **OK**.
5. Zoom to the **Typical Room Module** drawing in the upper left.
6. Click **Multi-Select**, and then click and drag to select all measurements.
7. Right-click the selection and select **Drawing Comparison > Move/Copy Measurements and Annotations**.
8. Move the measurements to the addenda sheet.
9. Open drawing **201 A403 Interior Elev – Addenda 1** and modify the area of the kitchen tile to accommodate the new counter depth.
Help topic: Drawing Legend Overview

The **Drawing Legend** (on the **View** tab) shows a grid of all traces in the active drawing. It is available only if at least one measurement is present on the drawing.

Click **Drawing Legend** to show or hide the legend. Click and drag the legend in the window to move it (a blue outline appears as a guide).

The quantities in the drawing legend [A] reflect the totals for the primary measurement (**Data Type 1**) as set for each trace.

Right-click the drawing legend [B] to see display options. Notice that you can specify the number of decimal places, whether summary or detail quantities are shown, transparency and borders, and so on. Selecting **New Drawing Legend** [C] lets you establish the drawing legend appearance for new drawings.

### Practice steps:
1. Open drawing **005 A1.2 Second Floor Plan**.
2. On the **View** tab, click **Drawing Legend**.
Layers

Traces, measurements, and annotations can be assigned to layers. In Settings > Edit Layers, you can show or hide layers based on what you need to see. You can set visibility for yourself [A] or for the drawing [B] which applies the setting to any user viewing that drawing. The two columns of icons in the Edit Layers window reflect the user and drawing settings, respectively.

In this example, the FLOORING – BASE layer is visible for this and all other users who open this drawing. The CARPET layer is visible to this user, and other users can display it as needed.

You can assign traces to layers [C], which automatically adds any measurements for that trace to the specified layer.

In this example, the CARPET layer [A] is hidden from view, so traces assigned to that layer are not visible. The FLOORING – BASE layer [B] is visible.
In this example, the CARPET layer is visible, so you see the shaded areas indicating traces assigned to this layer.

Practice steps:

1. Open drawing 005 A1.2 Second Floor Plan.
2. In Control Panel 2, click the down arrow and select Layer List.
3. Hide all layers except those that appear in bold in the list (indicating measurements are associated with those layers).
4. Right-click a measurement and select Edit Trace. Identify the layer with which the trace is associated.
Getting the most out of Dimension

Configuring extensions

**With the Premier edition:** If you need to collect additional information or perform calculations on quantities, such as specs or measurements not indicated in the drawing, you can configure extensions with additional variables and formulas, and modify them as needed.

On the **Settings** tab, click **Edit Extensions**. Select the extension you want to configure, and click **Edit**. In this example, the **Frame & Drywall – Wood** extension measures the length of walls to frame. In order to estimate the studs needed, you also need to collect the height of the wall. A variable called **WallHeight** has been added.

To add a variable, click **Add** and then select the data type. This creates an empty row, in which you can enter the variable name, description, and a default value or formula. Click the **Properties** button to configure the variable in more detail.
Configuring conditional logic with variables

Sometimes you only need to collect information for a variable if certain conditions are true. For example, you're measuring walls for framing and sheetrock, but you might not always need to hang the sheetrock—this is determined by the project specs.

In this example, the **# of Layers to Hang** variable lets the user enter the quantity of sheetrock layers are needed for each wall, and then enter the **Sheetrock Thickness** for that wall. However, if the wall does not require sheetrock, the **Sheetrock Thickness** variable is not needed. To accommodate this, the **Sheetrock Thickness** variable is set to a **Hide if Variable Zero** value of `#LayersToHang`.

This means that when the number of layers of sheetrock is zero, the **Sheetrock Thickness** variable is hidden in the **Quantity List**. If the number is non-zero, the **Sheetrock Thickness** variable appears.
Work Breakdowns (WBS Codes)

You can add work breakdown categories (also known as WBS codes) to your project by selecting **Settings > Work Breakdown**. Click **New** to add new categories, and then click to set up a list of values for the category.

Once the list is set up, use the **Control Panel Work Breakdown** pane to enter values for measurements as you work.

Help topics:
- Work Breakdowns Overview
- Work Breakdown Category Maintenance
- Work Breakdown Default Maintenance
- Project Restore Work Breakdown Window
Working with Zones

When you’re working with a drawing that represents a large horizontal area, you might want to view measurement quantities broken down into sections. For example, on a landscape plan, you’ll want trees to be delivered as close to the installation point as possible, so you need to know quantities for different areas of the drawing.

You can do this with Dimension zones, which are available on the Work Zones tab. This tab has options for adding zones, showing and hiding them, aligning them to each other, and formatting.

Zones let you break up measurements from individual traces into sections delineated by the zone boundaries, based on your quantification needs at different stages of the project.

In this example, all trees and shrubs have been counted, and the Measurement Summary shows the totals for the entire drawing. Notice that the total count for the Aristocrat Callery Pear is 23 [A].
To set up zones, on the Work Zones tab, click Rectangle Zone or Polygon Zone. Enter a description for the zone [A], and then draw a rectangle around the area you want to include. Notice that you can modify the appearance of zones to easily distinguish them [B].

Continue creating zones as needed. To make sure your zones butt up against each other (so portions of measurements are not excluded):

1. On the Work Zones tab, click Fix Gaps & Overlaps [A]. Notice that the cursor changes.
2. Click inside the first zone and drag your mouse into an adjacent zone [B] to remove any space between them. You’ll see the blue cursor trail indicating the direction. When you release the mouse, the first zone is adjusted to butt against the second one.
You can see that the 23 **Aristocreat Callery Pear** points are spread over all zones.

When you click **Work Zone Report**, you can see how many points fall into each zone. This window functions just like the **Measurement List** window (explained on page 21), except that it reflects zone information and won’t include measurements that do not fall into a zone.
Right-click the **Work Zone All** column header and select **Sort by “Work Zone All”, Ascending**. Then right-click the **Description** column header and select **Sub-Sort by “Description”, Ascending**. This shows the summary for each work zone and each trace.

Click the **Show/hide Measurement Detail** button to see only the total quantities for each trace in each zone. You can see that the quantities for the Aristocrat Callery Pear in all four zones add up to 23 (1, 7, 11, and 4 respectively).
Practice steps:

3. Double-click drawing 004 A1.1 First Floor Plan to open it.
4. Zoom out so you can see the entire drawing in the window.
5. On the Work Zones tab, click Rectangle Zone.
6. For the Description, enter Zone 1 and press Enter.
7. Draw a rectangle that covers the west end of the building up to the laundry and breakfast area.
8. Draw two or three other zones.
9. Click Work Zone Report to see how the quantities are listed.
Annotations

Use the Annotate tab to add the typical markups to your drawings where needed: text, lines and shapes, links, dimension callouts, and highlights.

With the Advanced edition: Hyperlinks let you add buttons to jump from the current view to another view of the active drawing or a different drawing.

In the example below, hyperlinks and text annotations have been added to a unit on a floor plan drawing. Double-clicking the top hyperlink opens the enlarged bathroom plan for standard double and king rooms. The annotations were then stored as Project Favorites.

The annotations can quickly be dragged to other drawings (or other areas of the same drawing) so you can quickly reference the enlarged plans as you complete measurements.
A Dimension annotation shows length [A], using the scaled measurements.

Two-way hyperlinks

When you create a Hyperlink, you can set it to include a link on the target drawing to return to the original location. You do this in the Hint window that opens when you create a link. The hyperlink retains the zoom and window position of each drawing at the time you set it up.

Practice steps:

1. Open drawing 006 A1.3 Third Floor Plan.
2. Zoom in to one of the SD rooms.
3. On the Annotate tab, click Hyperlink.
4. Click in one of the rooms.
5. Select the Create link back to original drawing check box.
6. Open drawing 008 A1.5 Unit Plans & Interior Elevations.
7. Zoom to detail 1 Standard Double Guest Room.
8. Click Set Destination. Test both links to make sure they work as expected.
Bid codes give you another way to organize and summarize your measurements by combining takeoff quantities from multiple different traces. Bid codes are also used when you export data to a spreadsheet or other application.

**NOTE:** Bid code links are one of three data types that you can transfer from the Measurement List window to an Excel spreadsheet. (For a detailed explanation, see “Excel Integration” on page 67.)

Bid codes are assigned to traces. (You can assign them to the trace for an individual measurement, or you can assign them to the standard trace type.) All traces using the same bid code are combined when you summarize by bid code. You can create your own list of standard bid codes (Settings > Edit Bidcodes), and then assign a bid code to each trace (Settings > Edit Traces).

When you perform takeoff using a trace that has an associated bid code, you can display the bid code in the Measurement List window. If you have Microsoft Excel integration set up, you can select
Copy/Drag Bid Code Links from the dropdown, and drag the bid codes to your spreadsheet.

**With the Advanced edition:** You can display bid codes in the Measurement List. You can also transfer bid code information to Microsoft Excel or another estimating application.

**Settings related to bid codes**

In Settings > User Preferences > Bid Codes tab, you can establish your bid code format, type of characters, and defaults when setting up bid codes.

![User Preferences](image)

### Practice steps:

1. On the Settings tab, click **Edit Bidcodes**. Add the following bid codes to the list:
   
   13150 Swimming Pool  
   13152 Pool Pumps  
   13157 Pool Sealants

2. Double-click drawing **063 S1.1 Foundation Plan** to open it.

3. Take an **Area** measurement of the swimming pool and spa.

4. Right-click one of the measurements and select **Edit Trace**.

5. Click the browse button next to **Bid Code**, and select **13150 Swimming Pool**.
Excel Integration

Help topics and videos:

- Excel Add-on
- Setting up the Excel Add-on for eTakeoff Dimension
- Excel Integration (Time: 5:36)

If you use Dimension’s Excel Integration add-on, you can copy measurements, formulas, or bid code links into an Excel spreadsheet and retain the link to your Dimension takeoff. As you add measurements, the quantities are summarized in Excel based on how you configure the integration.

You can transfer data between Dimension and Excel from either the Measurement List or the Quantity List.

NOTE: Dimension is not compatible with 64-bit Excel. You must use the 32-bit version.

Preparing to use the Add-on

In Dimension, go to Settings and click User Preferences. On the General tab, select Use Dimension Excel Add-on, and click OK.

In Excel, follow the instructions in the document Setting up the Excel Add-on for eTakeoff Dimension to enable the add-on.

TIP: Build a set of Excel templates with headers and formatting, and use these templates with the Excel add-on to produce professional, customized documents on the fly.
Using the Measurement List with Excel

You can copy and paste—or drag and drop—quantities from the Measurement List to Excel. This results in formulas in the Excel spreadsheet which are updated automatically from the project data.

In the Measurement List, select the type of entries to copy.

- In this example, Copy/Drag Measurement Links is selected [A]. To transfer quantities, select the values in the Measurement List and copy or drag them to Excel. Notice that the function added to each cell is EtkoMeasQty. This is because Copy/Drag Measurement Links was selected. Each measurement you selected is linked to a specific cell in Excel. As you continue to work in the project, the quantities are updated in Excel automatically.

- In this example, Copy/Drag Bid Code Links is selected. This results in a different formula—EtkoMeasBidQty.

\[
\text{EtkoMeasQty("Base - Carpet", "Perimeter"})
\]
If you select **Copy/Drag Values**, only the quantities are copied to Excel. Links to the project are not retained, and the values are not updated as you work in Dimension.

### Using the Quantity List with Excel

You can also copy and paste or drag and drop cells from the **Quantity List** to Excel. You have the same three options for the transfer method in this control panel: values, measurement links, or bid code links. Each method has the same result as when copying from the **Measurement List**.

Once you have linked values in Excel, you can right-click a quantity cell and select **eTakeoff Dimension Drill Down** to jump to the specific measurement.
Practice steps:

1. On the **Settings** tab, click **User Preferences**.
2. On the **General** tab, click **Use Dimension Excel Add-on**, and then click **OK**.
3. Open Microsoft Excel to a blank workbook. These steps are for Excel 2013 or 2016.
4. Right-click in the ribbon area and select **Customize the Ribbon**.
5. Click **Add-ins**, and then click **Go**.
6. Click **Browse**, and browse to `C:\Program Files (x86)\eTakeoff\Rview`. Double-click the file `eTkoExcel.xll`. Click **OK**.
7. In Dimension, double-click drawing **005 A1.2 Second Floor Plan** to open it.
8. In the **Measurement Summary**, click the **Measurement List** icon.
9. Click the dropdown and select **Copy/Drag Measurement Links**.
10. Select several cells including quantities, and drag them to your Excel spreadsheet.
11. Examine the formulas. In Dimension, perform new measurements and verify the results.
System Information and Licensing

This section provides an overview of the system architecture, data files, and licensing options for Dimension. It is not intended as a substitute for reading the full technical documentation. See the Installation & Licensing section of eTakeoff’s Support site for complete information.

System Architecture

Dimension is typically installed in one of three ways: 1) stand-alone on a single computer; 2) on multiple computers on a network, or 3) in a Citrix or Terminal Services environment. Each type of installation involves a specific arrangement of system components.

Dimension components

The installation configuration you select determines how Dimension components are organized on your network. These components include:

- The **Standards database** ([Dimension50StdsData.ctr](#)) includes the standard traces, scales, layers, extensions, and so on that are used for all projects.

- The **Project database** ([Dimension50ProjData.ctr](#)) includes project-specific data such as takeoff measurements, annotations, scales, and so on.

  **NOTE:** The standards and project databases must be located together, whether on a local drive or shared network drive.

- The **Dimension** application must be installed on workstations and any server or peer host from which you access the software. Dimension is not required on the database server or peer host if that computer will not be used for work in the application.

- The **Project Folder** is the Windows Explorer folder that holds the drawing files for each project. **Dimension** does not alter the drawing files themselves.

- A **License** to use Dimension must be available. Licenses are concurrent, and are explained in the next section.

  (Optional) The **c-Tree Server** application and service are required when some or all of your servers or workstations will access the Standards and Project databases across a network. This component optimizes performance and data integrity, and is licensed separately from Dimension. It is not required for stand-alone installations.

  **NOTE:** If users share only the project folder containing the drawings, but do not share Dimension databases, the c-Tree Server application and service are not required.
Licensing

Help topics:
- Dimension License Installation Window
- Concurrent Licensing Overview
- Concurrent License Window
- Dimension Add-on License Installation Window

Dimension licenses are purchased based on the number of concurrent users working in the software. Each Dimension license is associated with either the Advanced or Premier edition.

A **license** lets you share a specified number of **uses** across an organization. The license use count determines how many users can use Dimension at the same time. If you have a mix of Advanced and Premier users, one concurrent license is issued for each edition, with the appropriate number of use counts associated with each.

The **License Manager** is eTakeoff’s Cloud-based licensing system, which determines whether a use is available when you share a concurrent license. Each time the software opens with a shared license, Dimension communicates with this service over the Internet (although you can check out a license for disconnected (extended) use later. Your computer must be connected to the Internet when you launch Dimension to verify the number of available uses, but you can check out a license if you expect to be disconnected.

Stand-alone installation

In a stand-alone installation, the Dimension application and databases are installed on the same physical machine. The drawings folder can be on a local or a network drive accessible to the machine.

**NOTE:** The c-Tree Server application and service are not required for stand-alone installations.
Network Installation

In a typical network environment, Dimension is installed on clients, and all data is shared on a common server or peer host. Dimension can be installed on the server or peer host if users will work in the software from that computer, but this is not required. In network installations, the databases are separated from workstations, so c-Tree Server must be installed on the server or peer host.

Step-by-step installation instructions are provided in the “Helpful links” below. The information that follows is intended to provide an overview of possible configurations, not complete instructions.

System recommendations for eTakeoff Dimension can be found at the link below. In particular, see the section “Minimum Hardware Requirements for c-treeACE V10.” These apply to any workstation or server on which Dimension is installed.

Helpful links:
- Dimension Client/Server Installation and Configuration
- Using Dimension with Terminal Services
- Hardware and Software Recommendations
- eTakeoff Bridge – Overview (Time 13:24)

Standard network configuration

In a standard network configuration:

- The databases are stored on the network server, and each client accesses data over the network.
- Dimension is installed on client desktops. It is not required on the server or peer host.
- The c-Tree Server application and service must be installed on the server or peer host.
- The project drawings can be stored on the same server, or a different shared network drive—but all client workstations must be able to access the drawings. Drawings can also be stored on local drives for each client if they are not shared by multiple users.
- Workstations sharing a concurrent license must connect to the Internet to access eTakeoff’s cloud-based Concurrent License Manager.
Terminal Services (Citrix) environments

Terminal Services can be used in a stand-alone or networked configuration. The c-Tree Server application and service must be installed on the server in all Citrix environments.

**IMPORTANT:** Be sure to read the guide *Using Dimension with Terminal Services* before installing Dimension in a Terminal Services environment.

**Stand-alone Terminal Services (Citrix) installation**

In a stand-alone Terminal Services installation:

- Dimension, as well as the Standards and Project databases, are installed on the Citrix server.
- The c-Tree Server application and service are required in this scenario.
- A license with multiple uses is required in this scenario. If both Advanced and Premier users will access this server, a license of each type is required. Terminal Services servers must be connected to the Internet for license verification.
- Citrix must be configured to run each application instance in a separate session.
Terminal Services (Citrix) installation with multiple servers

If you implement Terminal Services with multiple servers to accommodate load balancing, high availability, or another objective:

- Dimension is installed on the Terminal Services server.
- All servers on which the Standards and Project databases are installed must also have the c-Tree Server application and service installed. These are not required on the Terminal Services server.
- A shared concurrent license is required in this scenario, as multiple users will access the software simultaneously. If both Advanced and Premier users will access this server, a license of each type is required. Terminal Services servers must be connected to the Internet for license verification.
- Citrix must be configured to run each application instance in a separate session.
Removing a license from a computer

If you need to remove a Dimension license from a computer, select File > Administration > Install Software License, and then click Un-Install. Click Yes to the confirmation message, and wait for the process to finish.

Back up and restore Dimension data

If you do not use eTakeoff Bridge to send Dimension data to Sage Estimating, you can back up and restore Dimension data using the links under File > Project Backup & Restore.

- Use Backup project to create a backup that you can restore later. This process creates a file with the extension .tpx, which you can restore to the same or a different computer. The .tpx file does not include the project drawings, so you might need to copy the drawings to a new location if you store them locally.

- Use Backup and zip project to transfer the project to a different computer or to another user. The zip file has the extension .tpxzip, and contains all project information from the Dimension database, plus all drawing files.

To restore a project from a backup when not using Bridge, select File > Project Backup & Restore > Restore project. Browse to the .tpx file and follow the prompts.

IMPORTANT: If you use eTakeoff Bridge and you want to create an archival backup of the entire project (including the estimate), use the project backup feature in Bridge to back up and restore your Dimension projects. This ensures that the backup retains the links between the Dimension project, the Bridge assignment history, and Sage Estimating.